community.general.aix_lvol 模块 – 配置 AIX LVM 逻辑卷
注意
此模块是 community.general 集合 (版本 10.1.0) 的一部分。
如果您使用的是 ansible
包,则可能已经安装了此集合。它不包含在 ansible-core
中。要检查它是否已安装,请运行 ansible-galaxy collection list
。
要安装它,请使用: ansible-galaxy collection install community.general
。
要在剧本中使用它,请指定: community.general.aix_lvol
。
概要
此模块创建、删除或调整 AIX 逻辑卷的大小。受 lvol 模块启发。
参数
参数 |
注释 |
---|---|
逻辑卷的副本数。 最大副本数为 3。 默认值: |
|
逻辑卷的名称。 |
|
逻辑卷的类型。 默认值: |
|
要传递给 mklv 命令的自由格式选项。 默认值: |
|
设置卷间物理卷分配策略。
选项
|
|
物理卷列表,例如 默认值: |
|
逻辑卷的大小,使用 [MGT] 单位之一。 |
|
此逻辑卷所属的卷组。 |
属性
属性 |
支持 |
描述 |
---|---|---|
支持:完全支持 |
可以在 |
|
支持:不支持 |
在差异模式下,将返回有关已更改内容(或可能需要在 |
示例
- name: Create a logical volume of 512M
community.general.aix_lvol:
vg: testvg
lv: testlv
size: 512M
- name: Create a logical volume of 512M with disks hdisk1 and hdisk2
community.general.aix_lvol:
vg: testvg
lv: test2lv
size: 512M
pvs: [ hdisk1, hdisk2 ]
- name: Create a logical volume of 512M mirrored
community.general.aix_lvol:
vg: testvg
lv: test3lv
size: 512M
copies: 2
- name: Create a logical volume of 1G with a minimum placement policy
community.general.aix_lvol:
vg: rootvg
lv: test4lv
size: 1G
policy: minimum
- name: Create a logical volume with special options like mirror pool
community.general.aix_lvol:
vg: testvg
lv: testlv
size: 512M
opts: -p copy1=poolA -p copy2=poolB
- name: Extend the logical volume to 1200M
community.general.aix_lvol:
vg: testvg
lv: test4lv
size: 1200M
- name: Remove the logical volume
community.general.aix_lvol:
vg: testvg
lv: testlv
state: absent
返回值
常见的返回值已在此处记录,以下是此模块特有的字段
键 |
描述 |
---|---|
描述任务结果的友好消息。 返回:始终 示例: |